DigitalEro Offline

For all texture problems (black/purple checkered squares!)

Sun, 16 Jun 2013 05:19:40

Brother Antroz

Fairly simple process for fixing that I'm only now getting around to! First, you'll need a program called VTFEdit available here: http://nemesis.thewavelength.net/index.php?c=178 - Secondly, once you've installed it, open up the foot_female/male.vtf (or foot_female_n.vtf) files or whichever is displaying the error, and select the File dropdown menu in the top lefthand corner. - Scroll down and click Export. Save it as *insertfilename*.tga - Once that's finished, open the File menu again, select Import this time and import the file you just exported. Leave all the settings in the first screen as they are! - Now that that's over with, save it as the original filename, and put it back in the directory. Get busy posin', or get busy fappin'! :twisted:
Sun, 16 Jun 2013 10:16:03

Rastifan

I got Lilith to work again in Gmod. Turns out it was the footfemale_n that was the bottleneck. Followed these steps and it worked. The normal footfemale.vtf file I did not need to touch. And moved to tutorials.
Sun, 16 Jun 2013 16:30:06

Brother Antroz

Thanks Rast. :D
Wed, 26 Jun 2013 22:16:11

DesperateTimes

"Brother Antroz" said ...
- Secondly, once you've installed it, open up the foot_female/male.vtf (or foot_female_n.vtf) files or whichever is displaying the error, and select the File dropdown menu in the top lefthand corner. - Scroll down and click Export. Save it as *insertfilename*.tga - Once that's finished, open the File menu again, select Import this time and import the file you just exported. Leave all the settings in the first screen as they are! - Now that that's over with, save it as the original filename, and put it back in the directory.
Sorry, I'm very inept with things like this, but when I try to import the .tga file in, it doesn't show up in the directory. It exports as a .tga file and show up in the place that I saved it. It also doesn't respond for a couple of minutes, but I'd imagine that it would be the loading of the file. I have a question also, is it required to import with the tool or can I just move it manually?
Wed, 26 Jun 2013 22:19:22

Brother Antroz

Yeah, it should show up where you saved it. Sorry if I didn't make that bit clear :oops: You can try dragging it onto the VTFE window, but I haven't tried it that way so I don't know if that function works.
Mon, 08 Jul 2013 00:07:22

FairyLiquidators

Uh, how do I know which one is popping the error in SFM?
Mon, 08 Jul 2013 00:14:23

Brother Antroz

Normally, I just go through a routine of checking all the body .vtfs, including the head and looking for which one doesn't have the flag.
Mon, 08 Jul 2013 00:28:29

FairyLiquidators

Well I figured that out now, but I'm having trouble with Zoey's body being completely checkered, I did the fix to all the culprits I could find an there didn't seem to be any change.
Mon, 08 Jul 2013 00:30:59

Brother Antroz

Are the file names the same as what the .vmts say they should be?
Wed, 10 Jul 2013 12:28:08

McHooligan78

You lose me at "open up foot_female/male.vtg............. where is that and how do i open it (program) :?: :?:
Wed, 10 Jul 2013 12:58:00

Rastifan

"McHooligan78" said ...
You lose me at "open up foot_female/male.vtg............. where is that and how do i open it (program) :?: :?:
Install this program http://nemesis.thewavelength.net/index.php?c=178 Link was in the op. Follow instructions. Also in the Op.
Thu, 11 Jul 2013 21:22:44

Qetesh

This worked wonders with Lilith, but I just can't seem to fix Jill... tried replacing all of the body textures as instructed and as already applied before, but she's still pink. Any help?
Sat, 20 Jul 2013 22:01:15

Vinthewolf

"Qetesh" said ...
This worked wonders with Lilith, but I just can't seem to fix Jill... tried replacing all of the body textures as instructed and as already applied before, but she's still pink. Any help?
Go back to the OP with Jill, and someone posted a fix for SFM, install it into the Garrysmod/garrysmod folder, but ONLY THE MATERIALS. Once you do that, it should be fine.
Sat, 20 Jul 2013 22:01:53

Vinthewolf

By the way, I'm having trouble with VTF edit, when I import, the program stops respond EDIT: Fixed the problem with loading, furthermore, you can find out exactly which files need replacing, by checking the console after spawning the model. For example: Error_loading_file: materials/models/Jill_nude/Foot_female_n
Sat, 20 Jul 2013 22:05:55

Brother Antroz

Apart from uninstalling and reinstalling VTFEdit, making sure you have the most recent version, I have no idea what could be causing that. Maybe a lack of space on your HD?
Sat, 20 Jul 2013 22:08:41

Vinthewolf

"Brother Antroz" said ...
Apart from uninstalling and reinstalling VTFEdit, making sure you have the most recent version, I have no idea what could be causing that. Maybe a lack of space on your HD?
Actually just fixed :) it was a problem with backround programs, closed them all out, and it worked like a charm, Thanks Antroz!! Definitely going to spend all day fixing models now, lol
Sat, 20 Jul 2013 22:10:40

Brother Antroz

Glad to hear it sir. Hope you'll post your results sometime! :D
Sat, 20 Jul 2013 22:14:05

Vinthewolf

"Brother Antroz" said ...
Glad to hear it sir. Hope you'll post your results sometime! :D
Definitely will. Is there any way that we may be able to collectively fix these models and re-upload them, for ease of future use?
Sat, 20 Jul 2013 22:15:28

Brother Antroz

Not sure about collectively fixing them. It may be possible to create a macro to do that, but that's a bit beyond me. And reuploading would definitely be helpful! Rastifan would be able to help with finding hosts for them once you run them through the wringer. ;)
Sat, 20 Jul 2013 22:21:09

Vinthewolf

"Brother Antroz" said ...
Not sure about collectively fixing them. It may be possible to create a macro to do that, but that's a bit beyond me. And reuploading would definitely be helpful! Rastifan would be able to help with finding hosts for them once you run them through the wringer. ;)
Aye, I'm honestly not sure how all this works, but I could try to fix models that people are having problems with, and find out how to re-upload patches, if that would help. (Kinda new to the forums lol) EDIT: Worked like a charm on Lilith. Face texture fixed, and patchy skin fixed. I am going to try with other models soon!
Sat, 20 Jul 2013 22:30:28

Brother Antroz

That would be a great help, I'm sure! From what I know, it's models made before a certain period that lost that bit of coding in the .vtf, mostly nude models and females at that.
Sat, 20 Jul 2013 22:52:33

Vinthewolf

"Brother Antroz" said ...
That would be a great help, I'm sure! From what I know, it's models made before a certain period that lost that bit of coding in the .vtf, mostly nude models and females at that.
After the 2013 update (months ago) The folders and formats were changed to be more efficient. Like, the materials and models folders, are now in the 2nd garrymod folder instead of the addons, and I think it uses slightly updated Vtf formats, so exporting and importing fixes any compatibility issues. Strange thing is, some Vtf's work and some don't. Some that I've noticed are really bad are actually old works posted by Ash. Like the nude zoey with bodygroups, that one is completely broken for me. The bodygroups appear, but when I check the console, there are countless files that need fixing, all I can say, is I will fix this one, but it will take me awhile to do so. I also have a fixed Jill folder, as well as lillith with all outfits. I'll get on fixing others some other time, soon though, not giving up :D
Sat, 20 Jul 2013 22:56:53

Brother Antroz

Ah, so in other words it's Valve's fault again. :mrgreen: Thanks for the hard work!
Sat, 20 Jul 2013 23:02:21

Vinthewolf

"Brother Antroz" said ...
Ah, so in other words it's Valve's fault again. :mrgreen: Thanks for the hard work!
haha yes, it's their fault again. Oh the update also broke the NPC poser tool. Strangely, some people have no problems with it, but most people are having script errors with that addon :( but oh well, anyway I gotta go, nice to talk with you :)
Sat, 20 Jul 2013 23:03:30

Brother Antroz

Likewise, and have fun. :D
Fri, 26 Jul 2013 03:34:04

Khan

Alright, so I did all the VTF files, all went fine. However the VMT files only let me import, so I still see the checker pattern, did I miss something?
Fri, 26 Jul 2013 03:46:03

Brother Antroz

I don't quite understand what you mean. You shouldn't need to redo the .vmts, just make sure the target in the .vmt matches the directory you're putting it in.
Fri, 26 Jul 2013 03:56:08

ajwill62

Using this method works for the most part :) Heres the materials i fixed for Excella and Claire Redfield if they look purple/black checkered to you. also, these materials are for gmod, im unsure about sfm. -- below is Excella Gionne ( the one with multiple hair color bodygroups ) http://filesmelt.com/dl/excella_materials_fixed.zip -- below is Claire Redfied http://filesmelt.com/dl/claire_redfield_materials_fixed.zip -- and here is Abigail the angel ( i didnt personally fix this one, there was a link on this site but i dunt remember who it was from, credit to whoever that was though ) http://filesmelt.com/dl/Abigail_materials_fixed.zip - i didnt know where to post fixes besides here ( *sidenote* that would be a good addition to the site ;D ... a Fixes section and also a Reskin section ) Also,, if anyone has working "Final Zoey Bodygrouped (high-res skin)" please upload them.. i was using this method to fix her but her skin looked ... really odd from certain distances,, idk i couldnt get her to work lol
Fri, 26 Jul 2013 04:14:00

Khan

Never mind, solved it. You already said it :oops:
Fri, 26 Jul 2013 04:27:22

Brother Antroz

"Khan" said ...
When I imported them, I was supposed to have named them into .vtf files rather then letting them stay as tga files, was'nt I...
Yes indeed! I apologize if I didn't mention that.
Mon, 05 Aug 2013 05:25:50

redsp1ke

I've been trying to get the "footfemale" texture from Evil-Ash's Cammy model to work in SFM for quite some time now, but replacing the texture files this way doesn't seem to work, no matter how many times I try. I know the model can work in SFM, as I've seen SFM animations and pictures with that model. Does any one who's got it working know what I have to do?
Thu, 08 Aug 2013 15:59:29

Peter Green

I don't know how this works or how you do it. I always get lost on "Find foot_female" etc things. A video would help
Sat, 31 Aug 2013 21:15:33

happywheel

"redsp1ke" said ...
I've been trying to get the "footfemale" texture from Evil-Ash's Cammy model to work in SFM for quite some time now, but replacing the texture files this way doesn't seem to work, no matter how many times I try. I know the model can work in SFM, as I've seen SFM animations and pictures with that model. Does any one who's got it working know what I have to do?
I cant seem to get her to work in gmod. She still comes out as black/purple checkers :cry:
Sun, 10 Nov 2013 17:34:02

peedidie

VTF is not working for me, i run the program after installing it but nothing happens, i have checked the task manager as well but nothing pops up there at all, i also tried installing .net 1.1 but it seems i have a later version or it is already installed. if you know what i am doing wrong please please notify me. Purple and black don't mix! :evil: yours sincerely Peddidie EDIT:it 's working now, you actually have an old version of the software as the link, the new one http://nemesis.thewavelength.net/index.php?p=41
Tue, 10 Dec 2013 17:10:34

Pu$$y

thanks guys really needed that to work cammy, you are the best :twisted:
Sun, 15 Dec 2013 00:47:36

HelghastPredator

OMG Brother Anthroz THANKS THANKS THANK YOU...fixed every broken model I had...dude...LIFESAVER!! :shock: As for the people that have the VTFEdit crash after importing: after clicking "import" don't touch anything until you see VTFEdit react again then it's ok to continue. If I clicked anything after importing while it was still loading VTFEdit would stop responding...just wait, sometimes it took 20 seconds. Hope this helped. Greets!
Mon, 23 Dec 2013 17:27:38

Headastator08

Thanks so much, really helped me to get a few models working again, not all purple checkered anymore! :D :D Thanks again- Headastator
Sun, 12 Jan 2014 22:22:30

bart0nboy

I'm not sure if this was addressed already but: I can't find female_foot for Nakha's Sandra. She is doing the greyish checkered bug where you can see skin yet light causes there to be a checkered pattern over it. Howeverer, there are like 5 different Sandara's folders for different outfits. I assumed the original skins would be in "Sandra Classic", but the only things there are "Female_body" and "Female_hands". Any help with this?
Sun, 12 Jan 2014 22:23:51

Ganonmaster

Just do all of them to be sure.
Mon, 13 Jan 2014 05:12:48

Rikolo

"bart0nboy" said ...
I'm not sure if this was addressed already but: I can't find female_foot for Nakha's Sandra. She is doing the greyish checkered bug where you can see skin yet light causes there to be a checkered pattern over it. Howeverer, there are like 5 different Sandara's folders for different outfits. I assumed the original skins would be in "Sandra Classic", but the only things there are "Female_body" and "Female_hands". Any help with this?
I was fixing Sandra recently, all you should need to fix is Female_body_n - bump map for her body. It worked for me.
Sun, 02 Feb 2014 17:24:35

toastpost

The Jill Valentine model didn't quite work out for me. The head is fine, but the body is all pink/black. She makes a good statue though lmao. Anyway, this is the first one to get these problems. I got it With the Zoey one too, but it was fixed when I downloaded the low-res package. Help? :????:
Sat, 08 Feb 2014 09:12:00

Anonymous

Every time I try exporting a file back to vtf, it says "error saving image". Can anyone help me?
Mon, 24 Feb 2014 00:58:33

LibertyPrime

"toastpost" said ...
The Jill Valentine model didn't quite work out for me. The head is fine, but the body is all pink/black. She makes a good statue though lmao. Anyway, this is the first one to get these problems. I got it With the Zoey one too, but it was fixed when I downloaded the low-res package. Help? :????:
It worked for me. No idea how, but I managed to find the file which needed to be changed without too much struggle. The OP mentions you need to open the file which corresponds to the body part which messed up. In Jill's case, her entire body was messed up. So I opened "Jill_body" in garrysmod\addons\jill_nude\materials\models\Jill_nude and followed the OP's steps. There are two "Jill_body" files in this folder. Just open the one which shows the actual body parts instead of a bunch of text. Export to wherever you want, rename it as the original file, then replace the faulty one with the one you just exported.
Tue, 11 Mar 2014 16:19:21

Playtime is Ogre

Thanks for this.
Sat, 22 Mar 2014 20:39:42

gummy

"Brother Antroz" said ...
Fairly simple process for fixing that I'm only now getting around to! First, you'll need a program called VTFEdit available here: http://nemesis.thewavelength.net/index.php?c=178 - Secondly, once you've installed it, open up the foot_female/male.vtf (or foot_female_n.vtf) files or whichever is displaying the error, and select the File dropdown menu in the top lefthand corner. - Scroll down and click Export. Save it as *insertfilename*.tga - Once that's finished, open the File menu again, select Import this time and import the file you just exported. Leave all the settings in the first screen as they are! - Now that that's over with, save it as the original filename, and put it back in the directory. Get busy posin', or get busy fappin'! :twisted:
none of this makes much sense to me. i have VTFEdit, but i have no idea how to use it.
Fri, 11 Apr 2014 20:01:40

mxm4shoot

Good job! :o But i fixed it with (autoexec): R_eyes 1 R_body 1