DigitalEro Offline

VTF Alpha Channel. Help please?

Tue, 29 Oct 2013 18:01:56

Disorder

While working on some recoloring of a clothed version of Elizabeth I figured maybe I could shorten her skirt by using an alpha channel on the vtf texture. The original vtf already has an alpha channel to blend the border of the long skirt nicely, but on me it never worked. So I tried the last hour to figure something out, but nothing works on me. I created a random alpha channel over the skirt and saved the VTF in the format RGBA8888 with selected 8bit alpha channel. With an unedited VMT vor the material nothing changes, the alpha channel seems useless. If I add "$Translucent 1" or "$Alphatest 1" to the vmt the alpha channel works fine and erases everything it should, but the whole texture itself gets translucent. Anybody has an idea what i could do about it? I would love to use the clothed elizabeth with a short skirt (reskinned with alphachannel ) in combination with the nude model to give her legs. I will provide you a screenshot of the translucent thingie and the content of the VMT file: VMT: vertexlitgeneric { "$basetexture" "models/BioshockInfinite/Elizabeth_clothed_tortured/Elizabeth_CORSET_TORTURE_D" "$bumpmap" "models/BioshockInfinite/Elizabeth_clothed_tortured/Elizabeth_CORSET_TORTURE_N" "$phong" "1" "$phongboost" "0.05" "$phongexponent" "1" "$phongtint" "[.85 .85 1]" "$phongfresnelranges" "[.5 .85 30]" "$alphatest" "1" } I hope you guys can help me!
Tue, 29 Oct 2013 21:54:41

Bilge Rat 16

I'm not an expert myself, but I think the culprit is "$Translucent". The following is the hair's VMT, which uses alpha channel in the same way you need for the skirt:
vertexlitgeneric
{
"$basetexture" 		"models/BioshockInfinite/Elizabeth_clothed_corset/Elizabeth_Hair_D_dark"
"$bumpmap" 			"models/BioshockInfinite/Elizabeth_clothed_corset/Elizabeth_Hair_N_dark"
$alphatest 1
$ambientocclusion 0
$nocull 1

	"$phong"				"1"
	"$phongboost"			"0.01"
	"$phongexponent"		"64"
	"$phongtint"			"[.85 .85 1]"
	"$phongfresnelranges"	"[.5 .85 30]"
}
Note that $alphatest is right under the texture path and without commas. I guess that's what you need to change. As a quick test I made the corset use the hair's texture. Using your settings the alpha channel did nothing. But using $alphatest as shown above everything worked fine.
The original vtf already has an alpha channel to blend the border of the long skirt nicely, but on me it never worked.
Aye, but the original VMT wasn't set up properly to use alpha channel at all. p.s. $nocull 1 makes both sides of the geoset visible. You might want to keep it in mind if you're going to cut a lot of that skirt.
Tue, 29 Oct 2013 22:11:19

Disorder

Oh wow, I think it actually works. "$basetexture" "models/BioshockInfinite/Elizabeth_clothed_tortured/Elizabeth_CORSET_TORTURE_D" "$bumpmap" "models/BioshockInfinite/Elizabeth_clothed_tortured/Elizabeth_CORSET_TORTURE_N" $alphatest 1 $ambientocclusion 0 $nocull 1 That did the trick like it seems. I maybe could've figured that out by myself with a bit more effort, but yelling for help was definitely the faster way because I never worked with all that stuff before. Thank you, you made my day. So that is basically a rough preview of what I am aiming at: