DigitalEro Offline

Delete polygons from a XnaLara model

Thu, 30 Jan 2014 20:56:28

Soloid

Hi there, I was wondering how to remove some polygons from an imported model of XNALara. For exemple, I have a model, boned and skinned, which works fine in 3DSmax. But the model also have weapons, and if I remove them manually, it messes up the skin modifier and the model becomes unusable. I tried to collapse the skin modifier, but it removes it also. Have an idea? Thanks.
Thu, 30 Jan 2014 21:14:17

Ganonmaster

"Soloid" said ...
For exemple, I have a model, boned and skinned, which works fine in 3DSmax. But the model also have weapons, and if I remove them manually, it messes up the skin modifier and the model becomes unusable.
It shouldn't mess up right away. Just select the mesh modifier without deleting the Skin modifier and remove the offending polygons. It might give you a warning about the Skin modifier being dependant on that modifier, but just ignore it/click continue or whatever. Remove the polygons/do your edits. Once you're done, make sure you exit out of vertex/edge/face/object selection mode, go up to your skin modifier and just deselect the model. Once you're ready to export, just select all the parts of your model + bones and export. It should work fine.
"Soloid" said ...
I tried to collapse the skin modifier, but it removes it also.
The skin modifier is the only thing that binds the polygons to the bones. Ofcourse it wouldn't work anymore of you removed it.
Thu, 30 Jan 2014 21:21:28

Soloid

Thanks for the reply! Hm.. I just tested it... But :/ I just ctrl+A and used the wall worm utility to export my model in .smd, but in the model viewer there seems to be no bones. Is it ok? Or should I check some boxes on the wall worm window? Thanks for helping me.
Thu, 30 Jan 2014 21:40:23

Ganonmaster

"Soloid" said ...
Or should I check some boxes on the wall worm window?
Make sure $staticprop is unchecked.
Thu, 30 Jan 2014 22:06:07

Soloid

"Ganonmaster" said ...
Make sure $staticprop is unchecked.
Yeah, it was not... But I've tried with another model, and the bones weren't the same. And it worked. Maybe it was some special skinning? I was working on the black rock shooter model, available here: http://sticklove.deviantart.com/art/Black-Rock-Shooter-376267179 Maybe if you have a bit of time to check it you'll understand better than me (certainly). Thanks again for the help, really.
Thu, 30 Jan 2014 22:12:50

Ganonmaster

"Soloid" said ...
"Ganonmaster" said ...
Make sure $staticprop is unchecked.
Yeah, it was not... But I've tried with another model, and the bones weren't the same. And it worked. Maybe it was some special skinning? I was working on the black rock shooter model, available here: http://sticklove.deviantart.com/art/Black-Rock-Shooter-376267179 Maybe if you have a bit of time to check it you'll understand better than me (certainly). Thanks again for the help, really.
You should try manually exporting the model and editting the QC file first. (without wallworm)